Metasploit

Վիքիպեդիայից՝ ազատ հանրագիտարանից
Изображение логотипа
Metasploit snapshot.png
Տեսակազատ ծրագրային ապահովում և ծրագրային ապահովում
Նախագծումը՝Rapid7?
Գրված է՝Ruby[1]
ՕՀմաքՕՍ[2], Վինդոուզ[2] և յունիքսանման օպերացիոն համակարգ[3]
Լույս տեսավ՝օգոստոս 2011
ՊլատֆորմՎինդոուզ[4], մաքՕՍ[4], BSD?[4] և Լինուքս[4]
Վերջին կայուն տարբերակ6.2.35 (հունվարի 12, 2023)[5]
Արտոնագիր3-clause BSD License?[6]
Սխալնելի հայտման էջgithub.com/rapid7/metasploit-framework/issues
Կայքmetasploit.com(անգլ.)
Աղբյուր կոդgithub.com/rapid7/metasploit-framework
Commons-logo.svg Metasploit Վիքիպահեստում

Metasploit Project, նախագիծ նվիրված տեղեկատվական անվտանգությանը։ Նախատեսված է խոցելիության մասին տեղեկության տրամադրման համար։ Առավել հայտնի է Metasploit Framework նախագիծը, որը նախատեսված է էքսպլոյիտների ստեղծման համար։ Բացի սա, նախագիծը իր մեջ պարունակում է օպերացիոն կոդերի բազա, շելլ կոդի արխիվ և տեղեկություն տեղեկատվական անվտանգության մասին։

Metasploit-ը ստեղծվել է 2003 թվականի հուլիսին։ 1․0 տարբերակը գրվել է Perl ծրագրավորման լեզվով և իր մեջ պարունակում է պսեվդոգրաֆիկական միջերես։ Ծրագրի հեղինակը դարձավ HD Moore-ը։ 2-րդ տարբերակի վրա աշխատելու ընթացքում HD Moore-ին միացան Մէտտ Միլլերը և մի քանի կամաորականներ։ Երրորդ տարբերակը ամբողջությամբ գրվել է Ruby լեզվով, այն մշակել է Metasploit LLC ընկերությունը։ 2008 թվականին Metasploit Framework-ի լիցենզիան փոխվեց այն ոչ-ազատ ծրագրային ապահովումից դարձավ ԲիԷսԴի։ 2009 թվականին Rapid7-ը, որը զբաղվում է խոցելիությունների ղեկավարմամբ, հայտարարեց, որ գնում է Metasploit-ը։ Ոչ ամբողջական տարբերակը ինչպես և առաջ հասանելի է բոլորի համար։

Metasploit-ի անվճար տարբերակը կարող է օգտագործվել ինչպես համակարգերի ադմիստրատորների և մասնագետների կողմից համակարգչի անվտանգության համար, այնպես էլ կարող է օգտագործվել հաքերների կողմից։

Metasploit Framework[խմբագրել | խմբագրել կոդը]

Գործիք, որը նախատեսված է էքսպլոյտների ստեղծման, թեսթավորման և օգատգործման համար։ Թույլ է տալիս կարգավորել էքսպլոյտները ըստ անհրաժեշտության։ Ինչպես նաև ծրագիրը թույլ է տալիս կոդավորել շելլկոդ, որը թույլ է տալիս թաքցնել IDS կամ IPS հարձակման փաստը։

Օպերացիոն կոդի բազա[խմբագրել | խմբագրել կոդը]

Այս գործիքը անհրաժեշտ է նոր էքսպլոյտներ գրելու համար։ Թույլ է տալիս գրել էքսպլոյտ, որը կարող է աշխատել տարատեսակ օպերացիոն համակարգերի հետ։

Գրականություն[խմբագրել | խմբագրել կոդը]

Արտաքին հղղումներ[խմբագրել | խմբագրել կոդը]

  1. https://www.linux-magazin.de/news/metasploit-3-0-setzt-auf-ruby/
  2. 2,0 2,1 Nightly Installers
  3. Nghtly Installers
  4. 4,0 4,1 4,2 4,3 https://github.com/rapid7/metasploit-framework/wiki/Nightly-Installers
  5. Release 6.2.35 — 2023.
  6. https://github.com/rapid7/metasploit-framework/blob/master/LICENSE