PhpMyAdmin

Վիքիպեդիայից՝ ազատ հանրագիտարանից
PhpMyAdmin
PhpMyAdmin logo.png
PhpMyAdmin-main-en.png
Տեսակ database management system և ազատ ծրագրային ապահովում
Նախագծումը՝ phpMyAdmin Developer Team
Գրված է՝ PHP և ՋավաՍկրիպտ
Առկա է բազմալեզու
Վերջին կայուն տարբերակ 4.6.3[1]
Արտոնագիր GPLv2
Սխալնելի հայտման էջ http://sourceforge.net/p/phpmyadmin/bugs/
Կայք http://www.phpmyadmin.net
Աղբյուր կոդ https://github.com/phpmyadmin/phpmyadmin
PhpMyAdmin Վիքիպահեստում

phpMyAdmin, PHP լեզվով գրված բաց կոդով վեբ-հավելված, որն իրենից ներկայացնում է վեբ-միջերես MySQL տվյալների բազաների կառավարման համակարգի համար։ phpMyAdmin-ը թույլ է տալիս բրաուզերի միջոցով կառավարել MySQL սերվերը, գործարկել SQL հրամաններ և դիտել աղյուսակների ու տվյալների բազաների բովանդակությունը։ Հավելվածը վեբ-մշակողների կողմից մեծ ճանաչման է արժանացել, քանի որ թույլ է տալիս առանց SQL հրամանների գրառման կառավարել MySQL ՏԲԿՀ-ը։

Հավելվածը տարածվում է GNU General Public License արտոնագրի ներքո, ինչի շնորհիվ այլ մշակողներ կարող են ներառել այն իրենց ծրագրերում։ Այդպիսի ներառումների օրինակ են XAMPP, Denwer, AppServ, Open Server և այլ վեբ-ծրագրավորման համար նախատեսված սերվերների փաթեթները։

Այսօր նախագիծը տեղայնացված է շուրջ 62 լեզուներով

Մշակողներ[խմբագրել | խմբագրել կոդը]

phpMyAdmin-ի մտքի հեղինակն է գերմանացի ծրագրավորող Տոբիաս Ռատշիլլերը (Tobias Ratschiller)։ Այն, ինչպես նաև phpPgAdmin-ը, կառուցված են MySQL-Webadmin հավելվածի հիման վրա, որը ստեղծվել է 1997 թ.-ին։

2001 թ.-ից phpMyAdmin նախագծի մշակումը Տոբիաս Ռատշիլլերից անցավ Մարկ Դելիսլին (Marc Delisle)։ Վերջինս, Օլիվեր Մյուլլերի (Olivier Müller) և Լոիկ Շապոյի հետ միասին սկսեց phpMyAdmin-ի մշակման նոր շրջանը։

Այսօր Մերկ Դելիսլը phpMyAdmin նախագծի ադմինիստրատորն է։ Նա phpMyAdmin-ի պատմության մեջ ունի ամենամեծ ներդրումը՝ գրված կոդի տեսքով։ Նախագծի հիմնական օգնականներն են Միխալ Ցիխարը (Michal Čihař), Սեբաստիան Մենդելն (Sebastian Mendel) ու Հերման վան Ռինկը (Herman van Rink)։

Տարբերակները[խմբագրել | խմբագրել կոդը]

Սկսած 3.0.0 տարբերակից, phpMyAdmin-ը միացել է GoPHP5 նախաձեռնությանը և հրաժարվել է PHP-ի և MySQL-ի հին տարբերակների աջակցությունից։ phpMyAdmin-ի 3.0.0 և ավելի բարձր տարբերակների հետ աշխատելու համար անհրաժեշտ է PHP 5.2 և MySQL 5։ PHP-ի և MySQL-ի հին տարբերակների հետ աշխատանքների համար շարունակում է զարգանալ phpMyAdmin 2.x տարբերակը, սակայն վերջինիս աջակցումը սահմանափակվում է գտնված խոցելի կետերի ուղղմամբ. նոր ֆունկցիաներ այդ տարբերակում այլևս չեն ավելացվում։

Ծանոթագրություններ[խմբագրել | խմբագրել կոդը]

Հղումներ[խմբագրել | խմբագրել կոդը]